upgradeneeded

The upgradeneeded handler is executed when an attempt was made to open a database with a version number higher than its current version.

General info

Specification
IndexedDB
Interface
Event
Bubbles
No
Cancelable
No
Target
IDBRequest
Default Action
None

Properties

Property Type Description
target Read only EventTarget The event target (the topmost target in the DOM tree).
type Read only DOMString The type of event.
bubbles Read only Boolean Whether the event normally bubbles or not.
cancelable Read only Boolean Whether the event is cancellable or not.

Example

var req1 = indexedDB.open("addressbook", 999);
 
req1.onupgradeneeded = function( event ) {
  // time for a versionchange transaction
 
};

// which is equivalent to
req1.addEventListener("upgradeneeded", function( event ) {
  // time for a versionchange transaction
 
});

See also

Document Tags and Contributors

 Contributors to this page: fscholz, teoli, Sheppy, ethertank, louisremi
 Last updated by: fscholz,