runtime.OnRestartRequiredReason

The reason that the onRestartRequired event is being dispatched.

Type

Values of this type are strings. Possible values are:

  • "app_update": The application is being updated to a newer version.
  • "os_update": The browser/OS is updated to a newer version.
  • "periodic": The system has run for more than the permitted uptime set in the enterprise policy.

Browser compatibility

Update compatibility data on GitHub
DesktopMobile
ChromeEdgeFirefoxOperaFirefox for Android
Basic supportChrome Full support YesEdge No support NoFirefox Full support 45Opera Full support YesFirefox Android Full support 48

Legend

Full support  
Full support
No support  
No support

Acknowledgements

This API is based on Chromium's chrome.runtime API. This documentation is derived from runtime.json in the Chromium code.

Microsoft Edge compatibility data is supplied by Microsoft Corporation and is included here under the Creative Commons Attribution 3.0 United States License.

Document Tags and Contributors

Contributors to this page: chrisdavidmills, wbamberg
Last updated by: chrisdavidmills,