不推荐的工具

This translation is incomplete. Please help translate this article from English

在devtools的开发过程中,我们添加了几个实验面板来尝试新的想法。并不是所有这些都被广泛采用,而且由于维护成本的原因,很少使用的面板最终被移除。

我们已经创建了这个不推荐使用或删除的面板列表。此页记录不推荐使用的面板和跟踪其删除的错误。尽管这些面板已经被删除,但是您仍然可以访问旧代码,并且有其他的web扩展,您可以尝试获得类似的功能。


当我们否决某个小组时,我们首先从社区获得反馈,以确定删除该小组的影响。一旦我们决定移除面板,我们将提供一条警告消息,最后,我们将从代码库中移除面板。


尝试激活已弃用的面板时,可能会看到警告消息,如下图所示:

此外,如果打开其中一个工具的面板,您还将看到有关删除该工具的警告消息。

草稿行

从firefox 70开始,scratchpad将被弃用 (bug 1565380).

它将在将来被删除(目前版本号未知)  (bug 1519103).

说明

scratchpad提供了一个测试javascript代码的环境。您可以编写、运行和检查与网页交互的代码的结果。

Screenshot of the Scratchpad window with a deprecation message

选择

您可以在web控制台中编写多行javascript代码,使其类似于scratchpad。如果您在控制台中输入的javascript代码可以解释为多行语句的开头, Enter 在输入中添加新行,您可以使用 Ctrl + Enter (Cmd + Enter 在 macOS).

Screenshot of the Webconsole multiline input, showing an evaluation with a Syntax Error and another, correct one.

在计算时,输入不会被清除,这使得在代码片段上快速排列成为可能。


结果显示在控制台输出中,在输入的右侧,提供即时反馈。与scratchpad不同,错误在输出中以可扩展的stacktrace正确显示,这使得调试当前编写的代码更加容易。

WebIDE和连接页

WebIDE在Firefox 69中被弃用

从 Firefox 70 弃用 (bug 1539451).

从 Firefox 71 删除 (bug 1539462).

说明

webide允许您将firefox开发工具连接到远程浏览器,比如firefox for android。它还旨在支持firefox操作系统的应用程序开发。

选择

远程调试可在  “关于:从Firefox 68开始调试”  中找到。未移植到about的功能有:wifi调试,firefox for android,应用程序开发。已计划但尚未移植的功能:远程浏览器屏幕截图和编辑远程浏览器配置。有关邮件列表线程的更多详细信息。

Canvas 调试器

Bugzilla 问题: bug 1403938

从Firefox 67删除

说明

canvas调试器允许用户检查canvas元素并查看给定函数的调用频率。由于没有使用,它被弃用了。


我们没有画布调试器的专用文档。

Alternatives

Spector.js 是一个webextension,可以为这些特性提供3d说明文。

Web Audio editor(网络音频编辑器)

Bugzilla 问题: bug 1403944

从Firefox 67删除

说明

web音频编辑器允许您检查在页面中构造的音频上下文,并提供其图形的可视化。这提供了其操作的高级视图,并使您能够确保所有节点都按预期方式连接。可以为图中的每个节点编辑audioparam属性。一些非AudioParam属性,如振荡节点的类型属性,也被显示和编辑。由于没有使用,它被弃用了。


更多关于Web Audio Editor

选择

替代方案包括 AudioNhttps://github.com/spite/WebAudioExtension web extensions.

Shader editor

Bugzilla 问题: bug 1342237

从Firefox 67删除

说明

The Shader Editor

允许用户检查和编辑webgl顶点和片段着色器的源。由于使用和维护成本较低,已弃用。


更多关于Shader Editor

Alternatives

此面板的另一个选择是此扩展:https://github.com/spite/ShaderEditorExtension, 或 Spector.js 还支持一个着色器编辑器,该编辑器需要一个库来使用着色器重载器挂钩。目前只有巴比伦图书馆。