mozilla
您的搜索结果

    Site Compatibility for Firefox 28

    DOM

    PluginArray 接口, 通常就是指 window.navigator.plugins 属性, 现在不再是可以枚举的了. 这么做主要是为了防止网站通过某些技术手段窃取用户隐私. 不过开发人员仍然可以使用 window.navigator.mimeTypes 接口来判断浏览器支持哪些 MIME 类型. 这一变更可能会给一些已有的代码带来兼容性问题.

    showModalDialog has been deprecated

    The window.showModalDialog method, originally from Internet Explorer, is now considered deprecated. The window.open method should be used instead.

    Make sure the deep argument is specified for cloneNode and importNode

    The Node.cloneNode and document.importNode methods take the boolean deep argument. It's optional in the DOM4 specification, and if omitted, these methods acted as if the value of deep was true. But this behavior has been changed in the latest spec, and if omitted, the methods will act as if the value was false. Though It's still optional, Firefox now warns developers in console not to omit the argument for the forward compatibility.

    History objects now throw if the document is inactive

    The spec of the History interface has been updated, and the properties and methods now throw a SecurityError exception when those are called on an inactive document. It would be a problem if you are manipulating window.history in an <iframe>.

    Networking

    SPDY/2 support has been dropped

    The support of SPDY Protocol Draft 2 has been removed. Web sites should upgrade to SPDY/3 or 3.1.

    Video/Audio

    canPlayType('video/webm') now returns 'maybe'

    The canPlayType method of the HTMLMediaElement interface has been updated to comply with the spec. canPlayType('video/webm') and canPlayType('audio/webm') now return 'maybe' instead of 'probably', because media can be encoded with a codec that Firefox doesn't support. If a codec is specified in the type argument, the method returns 'probably' or '' (empty string) depending on the codec. For example, canPlayType('video/webm; codecs=vp8') returns 'probably'.

    文档标签和贡献者

    此页面的贡献者有: ziyunfei
    最后编辑者: ziyunfei,