Revision 190593 of Linux Build Prerequisites

  • 리비전 슬러그: Linux_Build_Prerequisites
  • 리비전 제목: Linux Build Prerequisites
  • 리비전 아이디: 190593
  • 제작일시:
  • 만든이: Molla
  • 현재 리비전인가요? 아니오
  • 댓글 Linux에서 build 부분 영문 copy

리비전 내용

Hardware

  • 512MB RAM with lots of available swap space. For static and XULRunner builds, 1GB RAM minimum. Additional RAM will significantly decrease build time.
  • For debug builds: at least 1.5 GB free disk space (2 GB recommended)
  • For optimized builds: at least 300 MB free disk space (500 MB recommended)

Simplified bundles

On Debian and Ubuntu family simply use apt-get build-dep mozilla-firefox. It'll install everything required to build Debian's Firefox package.

Build Tools

  • A recent POSIX Shell
  • A C++ compiler. GCC 3.2 or higher is recommended, or your platform's native C/C++ compiler.
  • Perl 5.6 or higher Older perl versions may work if you upgrade File::Spec to version 0.8
  • GNU make 3.79.1 or higher. Other varieties of "make" will not work.
  • CVS 1.11 or higher
  • A widget toolkit. GTK2 is the "standard" toolkit, and GTK (1.2.0 or higher) is also well-tested. QT and plain xlib configure options are available, but they not well tested or supported.
  • libXt-devel for X11/Intrinsic.h, X11/Shell.h
  • libIDL 0.6.3 or higher Source snapshots are available from Mozilla via ftp. If using the RPMs, you'll need both the regular rpm and the -devel rpm. If you already have ORBit installed, then you do not need to install libIDL as ORBit bundles libIDL. You may need to install the ORBit-devel package if you use packages.
  • zip 2.3 (or higher)
  • freetype 2.1.0 (or higher)
  • fontconfig
  • pkgconfig 0.9.0 (or higher)

Optional Software

  • Autoconf 2.13 (which requires GNU m4) is necessary if you want to hack on configure.in. If you have no idea what this means, then don't worry about it. It's optional. Autoconf 2.5x will not work. See {{template.Bug(104642)}} for details.

Additional Information

  • The default /bin/sh that comes with some older unices (notably OSF/1) is known to be deficient. In that case, you should use 'gmake SHELL=ksh'.
  • If you're using a glibc 2.07 system, you need this patch
  • gcc 2.95.2 (or higher) will also work, but has a different C++ ABI, which means that many extensions and plugins will be incompatible and may cause crashes
  • Redhat 7.0 users, the compiler distributed with RH 7.0 is buggy, and it is recommended that you upgrade to the latest gcc 2.9x compiler (2.96-77 or later). You need the packages named gcc-c++, gcc, and cpp.
  • If you're using GCC 3.3.x with gnome-vfs2 2.2.5 (the latter is included in RHEL3, but RHEL3 ships with GCC 3.2.x), you may run into {{template.Bug(324577)}}; the attached patch will fix it.
  • If a build on Fedora Core 6 fails because bfd.h can't be found, install the binutils-devel package.
{{ wiki.languages( { "it": "it/Linux_Build_Prerequisites", "fr": "fr/Pr\u00e9alables_\u00e0_la_compilation_sous_Linux", "ja": "ja/Linux_Build_Prerequisites", "zh-cn": "cn/Linux_Build_Prerequisites" } ) }}

리비전 소스

<h3 name="Hardware"> Hardware </h3>
<ul><li>  512MB RAM with lots of available swap space.  For static and XULRunner builds, 1GB RAM minimum. Additional RAM will significantly decrease build time.
</li><li> For debug builds: at least 1.5 GB free disk space (2 GB recommended)
</li><li> For optimized builds: at least 300 MB free disk space (500 MB recommended)
</li></ul>
<h3 name="Simplified_bundles"> Simplified bundles </h3>
<p>On Debian and Ubuntu family simply use <code>apt-get build-dep mozilla-firefox</code>. It'll install everything required to build Debian's Firefox package.
</p>
<h3 name="Build_Tools"> Build Tools </h3>
<ul>
<li>A recent POSIX Shell

</li><li>A C++ compiler. <a class="external" href="http://gcc.gnu.org/">GCC 3.2</a> or higher is recommended, or your platform's native C/C++ compiler.

</li><li><a class="external" href="http://www.perl.com/pub/language/info/software.html">Perl</a> 5.6 or higher
Older perl versions may work if you upgrade <a class="external" href="http://search.cpan.org/~kwilliams/File-Spec/">File::Spec</a> to version 0.8

</li><li><a class="external" href="http://www.gnu.org/software/make/">GNU make</a> 3.79.1 or higher. <i>Other varieties of "make" will not work.</i>

</li><li><a class="external" href="http://www.mozilla.org/cvs.html">CVS</a> 1.11 or higher

</li><li>A widget toolkit. <a class="external" href="http://www.gtk.org/">GTK2</a> is the "standard" toolkit, and GTK (1.2.0 or higher) is also well-tested. QT and plain xlib configure options are available, but they not well tested or supported.

</li><li>libXt-devel for X11/Intrinsic.h, X11/Shell.h

</li><li>libIDL 0.6.3 or higher
Source snapshots are available from Mozilla via <a class="external" href="ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/SRPMS/">ftp</a>. If using the RPMs, you'll need both the regular rpm and the -devel rpm.

If you already have <a class="external" href="http://www.labs.redhat.com/orbit/">ORBit</a> installed, then you do not need to install libIDL as ORBit bundles libIDL. You may need to install the ORBit-devel package if you use packages.

</li><li><a class="external" href="http://www.info-zip.org/">zip</a> 2.3 (or higher)

</li><li><a class="external" href="http://freetype.org/">freetype</a> 2.1.0 (or higher)

</li><li><a class="external" href="http://fontconfig.org/">fontconfig</a>

</li><li><a class="external" href="http://www.freedesktop.org/software/pkgconfig">pkgconfig</a> 0.9.0 (or higher) 
</li></ul>
<h3 name="Optional_Software"> Optional Software </h3>
<ul>
<li><a class="external" href="http://www.gnu.org/software/autoconf/">Autoconf 2.13</a> (which requires <a class="external" href="http://www.seindal.dk/rene/gnu/">GNU m4</a>) is necessary if you want to hack on configure.in. If you have no idea what this means, then don't worry about it. It's optional.
Autoconf 2.5x will <b>not</b> work. See {{template.Bug(104642)}} for details.
</li></ul>
<h3 name="Additional_Information"> Additional Information </h3>
<ul><li> The default /bin/sh that comes with some older unices (notably OSF/1) is known to be deficient. In that case, you should use 'gmake SHELL=ksh'.
</li><li> If you're using a glibc 2.07 system, you need <a class="external" href="ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/source/glibc-2.0.7-dlopen.patch">this patch</a>
</li><li> gcc 2.95.2 (or higher) will also work, but has a different C++ ABI, which means that many extensions and plugins will be incompatible and may cause crashes
</li><li> Redhat 7.0 users, the compiler distributed with RH 7.0 is buggy, and it is recommended that you upgrade to the latest gcc 2.9x compiler (2.96-77 or later). You need the packages named gcc-c++, gcc, and cpp.
</li><li> If you're using GCC 3.3.x with gnome-vfs2 2.2.5 (the latter is included in RHEL3, but RHEL3 ships with GCC 3.2.x), you may run into {{template.Bug(324577)}}; the <a class="external" href="https://bugzilla.mozilla.org/attachment.cgi?id=209521">attached patch</a> will fix it.
</li><li> If a build on Fedora Core 6 fails because bfd.h can't be found, install the binutils-devel package.
</li></ul>
{{ wiki.languages( { "it": "it/Linux_Build_Prerequisites", "fr": "fr/Pr\u00e9alables_\u00e0_la_compilation_sous_Linux", "ja": "ja/Linux_Build_Prerequisites", "zh-cn": "cn/Linux_Build_Prerequisites" } ) }}
현재 리비전 복원