MDN may have intermittent access issues April 18 13:00 - April 19 01:00 UTC. See whistlepig.mozilla.org for all notifications.

mozilla

リビジョンの比較

Linux Build Prerequisites

Change Revisions

リビジョン 169234:

リビジョン 169234 (編集者: Mgjbot / 編集日時: )

リビジョン 169235:

リビジョン 169235 (編集者: Electrolysis / 編集日時: )

タイトル:
Linux Build Prerequisites
Linux Build Prerequisites
URL スラグ:
Developer_Guide/Build_Instructions/Linux_Build_Prerequisites
Developer_Guide/Build_Instructions/Linux_Build_Prerequisites
タグ:
"Developing Mozilla", "Build documentation"
"Developing Mozilla", "Build documentation"
内容:

リビジョン 169234
リビジョン 169235
n27      <li>C++ コンパイラ。<a class="external" href="http://gcc.gnu.org/n27      <li>C++ コンパイラ。<a class="external" href="http://gcc.gnu.org/
>">GCC 3.2</a> 以降を推奨。またはお使いのプラットフォームのネイティブな C/C++ コンパイラ。>">GCC 3.3</a> 以降を推奨。またはお使いのプラットフォームのネイティブな C/C++ コンパイラ。
n38      <li>ウィジェットツールキット。<a class="external" href="http://www.gtk.on38      <li>
>rg/">GTK2</a> が「標準の」ツールキットです。GTK(1.2.0 以降)も十分にテストされています。QT や簡素な x 
>lib を configure オプションに指定することもできますが、あまりテストやサポートがされていません。 
39        <a class="external" href="http://www.gtk.org/">GTK2</a> ウ
 >ィジェットツールキット。バージョン 2.10 以降。
n54        <a class="external" href="http://www.freedesktop.org/softn55        <a class="external" href="http://pkgconfig.freedesktop.or
>ware/pkgconfig">pkgconfig</a> 0.9.0 以降>g/wiki/">pkg-config</a> 0.9.0 以降
nn58    <p>
59      Debian 派生あるいは Ubuntu 派生のシステムを使用している場合、<code>apt-get build-d
 >ep firefox</code> か <code>apt-get build-dep mozilla-firefox</code
 >> のどちらを使うことで必要なもののほとんどを取得することができるかもしれません。crashreporter をビルドする場合は 
 ><code>libcurl-dev</code> パッケージも必要です。(Ubuntu では <code>libcurl4-ope
 >nssl-dev</code> か <code>libcurl4-gnutls-dev</code> で提供されています。)
60    </p>
t72      <li>gcc 2.95.2 以降も動作しますが、別の C++ ABI がある場合、多くの拡張機能やプラグインが非互換t76      <li>Fedora Core 6 で bfd.h が見つからないためにビルドが失敗する場合は、binutils-de
>になり、クラッシュするかもしれません。>vel パッケージをインストールしてください。
73      </li>
74      <li>Redhat 7.0 ユーザの方へ:RH 7.0 で配布されているコンパイラはバギーなので、最新の gcc 2
>.9x コンパイラ(2.96-77 以降)にアップグレードしてください。gcc-c++、gcc、そして cpp という名前のパッケ 
>ージが必要です。 
75      </li>
76      <li>GCC 3.3.x を gnome-vfs2 2.2.5 とともに使用している場合(後者は RHEL3 に含ま
>れるが、RHEL3 は GCC 3.2.x を搭載)、{{template.Bug(324577)}} を参照するのがよいでしょう 
>。<a class="external" href="https://bugzilla.mozilla.org/attachmen 
>t.cgi?id=209521">添付されたパッチ</a> を使用すると修正されます。 

前に戻る