Confronta le versioni

Linux Build Prerequisites

Change Revisions

Versione 191331:

Versione 191331 di Vascaman del

Versione 191332:

Versione 191332 di Vascaman del

Titolo:
Linux Build Prerequisites
Linux Build Prerequisites
Slug:
Linux_Build_Prerequisites
Linux_Build_Prerequisites
Etichette:
Documentazione_build
Documentazione_build
Contenuto:

Versione 191331
Versione 191332
n30    <h3 name="Build_Tools">n30    <h3 name="Strumenti_di_Sviluppo">
31      Build Tools31      Strumenti di Sviluppo
n34      <li>A recent POSIX Shelln34      <li>Una Shell POSIX recente.
n36      <li>A C++ compiler. <a class="external" href="http://gcc.gnn36      <li>Un compilatore C++. E' consigliato <a class="external" 
>u.org/">GCC 3.2</a> or higher is recommended, or your platform's >href="http://gcc.gnu.org/">GCC 3.2</a> o superiore, oppure il com
>native C/C++ compiler.>pilatore C/C++ della piattaforma stessa.
n39        <a class="external" href="http://www.perl.com/pub/languagn39        <a class="external" href="http://www.perl.com/pub/languag
>e/info/software.html">Perl</a> 5.6 or higher Older perl versions >e/info/software.html">Perl</a> 5.6 o supperiore Le versioni piu' 
>may work if you upgrade <a class="external" href="http://search.c>vecchie di perl andranno bene se i <a class="external" href="http
>pan.org/~kwilliams/File-Spec/">File::Spec</a> to version 0.8>://search.cpan.org/~kwilliams/File-Spec/">File::Spec</a> saranno 
 >aggiornati alla verisone 0.8
n42        <a class="external" href="http://www.gnu.org/software/makn42        <a class="external" href="http://www.gnu.org/software/mak
>e/">GNU make</a> 3.79.1 or higher. <i>Other varieties of "make" w>e/">GNU make</a> 3.79.1 o supperiore or higher. <i>Altre varianti
>ill not work.</i>> di "make" non funzioneranno.</i>
n45        <a class="external" href="http://www.mozilla.org/cvs.htmln45        <a class="external" href="http://www.mozilla.org/cvs.html
>">CVS</a> 1.11 or higher>">CVS</a> 1.11 o supperiore
n47      <li>A widget toolkit. <a class="external" href="http://www.n47      <li>Un toolkit widget. <a class="external" href="http://www
>gtk.org/">GTK2</a> is the "standard" toolkit, and GTK (1.2.0 or h>.gtk.org/">GTK2</a> e'il toolkit "standard", anche GTK (1.2.0 o s
>igher) is also well-tested. QT and plain xlib configure options a>upperiore) ha dato buoni riscontri. Le QT e le operazioni di conf
>re available, but they not well tested or supported.>igurazione di xlib sono disponibiliQT , anche se non sono testate
 > o supporate.
n49      <li>libXt-devel for X11/Intrinsic.h, X11/Shell.hn49      <li>libXt-devel per X11/Intrinsic.h, X11/Shell.h
n51      <li>libIDL 0.6.3 or higher Source snapshots are available fn51      <li>libIDL 0.6.3 o supperiore Snapshots del codice sono dis
>rom Mozilla via <a class="external" href="ftp://ftp.mozilla.org/p>ponibile su Mozilla via <a class="external" href="ftp://ftp.mozil
>ub/mozilla.org/mozilla/libraries/SRPMS/">ftp</a>. If using the RP>la.org/pub/mozilla.org/mozilla/libraries/SRPMS/">ftp</a>. Se si u
>Ms, you'll need both the regular rpm and the -devel rpm. If you a>sa l'RPMs, ci sara' bisogno di rpm e di -devel rpm. Se si ha gia'
>lready have <a class="external" href="http://www.labs.redhat.com/> installato If you already have <a class="external" href="http://
>orbit/">ORBit</a> installed, then you do not need to install libI>www.labs.redhat.com/orbit/">ORBit</a>, non ci sara' bisogno di in
>DL as ORBit bundles libIDL. You may need to install the ORBit-dev>stallare libIDL come pacchetti ORBit libIDL. Si potrebbe presenta
>el package if you use packages.>re il bisogno di installare il package ORBit-devel package.
n54        <a class="external" href="http://www.info-zip.org/">zip</n54        <a class="external" href="http://www.info-zip.org/">zip</
>a> 2.3 (or higher)>a> 2.3 (o supperiore)
n57        <a class="external" href="http://freetype.org/">freetype<n57        <a class="external" href="http://freetype.org/">freetype<
>/a> 2.1.0 (or higher)>/a> 2.1.0 (o supperiore)
t63        <a class="external" href="http://www.freedesktop.org/softt63        <a class="external" href="http://www.freedesktop.org/soft
>ware/pkgconfig">pkgconfig</a> 0.9.0 (or higher)>ware/pkgconfig">pkgconfig</a> 0.9.0 (o supperiore)

Torna allo storico