Compatibilité des navigateurs

  • Raccourci de la révision : persona/Browser_compatibility
  • Titre de la révision : Browser compatibility
  • ID de la révision : 314057
  • Créé :
  • Créateur : sylvie
  • Version actuelle ? Non
  • Commentaire

Contenu de la révision

Navigateurs supportés

Persona est développé, testé, et supporté par les navigateurs suivants.  Grâce à la bibliothèque Javascript inter plateformes de Persona, les utilisateurs n'ont pas besoin d'add-ons pour utiliser Persona.

Navigateurs pour ordinateur de bureau
Internet Explorer 8.0*, 9.0
Firefox Versions Courante, Stable, Beta, Aurora, Nightly, et Support Etendu.
Précédante Version Stable
Chrome Dernière Version Stable
Safari Dernière Version Stable
Opera Dernière Version Stable
Navigateurs iOS
Mobile Safari iOS 5.x — 6.x
Navigateurs Android
Default Browser 2.x — 4.x
Firefox Versions Stable Courante, Beta, Aurora, et Nightly Précédante Version Stable
Chrome Dernière Version Stable

*: Pour Windows XP. : Pour Windows Vista et Windows 7. : selon durée de vie.

Navigateurs non supportés

  • Internet Explorer versions 6.0 and 7.0 non supportées. Les utilisateurs seront incités à mettre à jour leur navigateur.
  • Google Chrome Frame non supporté et ne fonctionne pas. Le support pourra être ajouté par la suite (Issue #796).
  • Les navigateurs tierces sur iOS ne sont pas supportés et ne fonctionnent pas. Le support pourra être ajouté par la suite (Issue #1870, Issue #2034).

Autres Navigateurs

Bien qu'ils ne soient pas explicitement supportés, un navigateur incluant les deux {{ domxref("window.postMessage()") }} et {{ domxref("Storage", "localStorage") }} devrait fonctionner. Ces APIs ont été rendues disponibles dans les principaux navigateurs depuis mars 2010.

Questions connues

  • Les navigateurs doivent accepter les cookies tiers pour un bon fonctionnement (Issue #1352).
  • Les utilisateurs Android 2.x qui n'ont pas sélectionné de navigateur par défaut ne pourront pas se connecter (Issue #1854).
  • Quand l'émulation IE8 est forcée, Internet Explorer 9 peut échouer lors de la connection sur les sites.

Source de la révision

<h2 id="Supported_Browsers">Navigateurs supportés</h2>
<p>Persona est développé, testé, et supporté par les navigateurs suivants.&nbsp; Grâce à la bibliothèque Javascript inter plateformes de Persona, les utilisateurs n'ont pas besoin d'add-ons pour utiliser Persona.</p>
<table>
  <tbody>
    <tr>
      <th colspan="3" scope="row" style="text-align: center; background-color: #d3d7cf"><strong>Navigateurs pour ordinateur de bureau</strong></th>
    </tr>
    <tr>
      <th scope="row"><strong>Internet Explorer</strong></th>
      <td colspan="2" rowspan="1" style="background-color: #8ae234">8.0<sup>*</sup>, 9.0<sup>†</sup></td>
    </tr>
    <tr>
      <th scope="row"><strong>Firefox</strong></th>
      <td colspan="2" style="background-color: #8ae234">Versions Courante, Stable, Beta, Aurora, Nightly, et Support Etendu.<br />
        Précédante Version Stable</td>
    </tr>
    <tr>
      <th scope="row"><strong>Chrome</strong></th>
      <td colspan="2" style="background-color: #8ae234">Dernière Version Stable</td>
    </tr>
    <tr>
      <th scope="row"><strong>Safari</strong></th>
      <td colspan="2" style="background-color: #8ae234">Dernière Version Stable</td>
    </tr>
    <tr>
      <th scope="row"><strong>Opera</strong></th>
      <td colspan="2" style="background-color: #8ae234">Dernière Version Stable<sup>‡</sup></td>
    </tr>
    <tr>
      <th colspan="3" scope="row" style="text-align: center; background-color: #d3d7cf"><strong>Navigateurs iOS</strong></th>
    </tr>
    <tr>
      <th scope="row"><strong>Mobile Safari</strong></th>
      <td colspan="2" rowspan="1" style="background-color: #8ae234">iOS 5.x — 6.x</td>
    </tr>
    <tr>
      <th colspan="3" scope="row" style="text-align: center; background-color: #d3d7cf"><strong>Navigateurs Android</strong></th>
    </tr>
    <tr>
      <th scope="row"><strong>Default Browser</strong></th>
      <td colspan="2" rowspan="1" style="background-color: #8ae234">2.x — 4.x</td>
    </tr>
    <tr>
      <th scope="row"><strong>Firefox</strong></th>
      <td colspan="2" style="background-color: #8ae234">Versions Stable Courante, Beta, Aurora, et Nightly Précédante Version Stable</td>
    </tr>
    <tr>
      <th scope="row"><strong>Chrome</strong></th>
      <td colspan="2" style="background-color: #8ae234">Dernière Version Stable</td>
    </tr>
  </tbody>
</table>
<p><sup>*</sup>: Pour Windows XP. <sup>†</sup>: Pour Windows Vista et Windows 7. <sup>‡</sup>: selon durée de vie.</p>
<h2 id="Unsupported_Browsers">Navigateurs non supportés</h2>
<ul>
  <li>Internet Explorer versions 6.0 and 7.0 non supportées. Les utilisateurs seront incités à mettre à jour leur navigateur.</li>
  <li>Google Chrome Frame non supporté et ne fonctionne pas. Le support pourra être ajouté par la suite (<a href="https://github.com/mozilla/browserid/issues/796" title="https://github.com/mozilla/browserid/issues/796">Issue #796</a>).</li>
  <li>Les navigateurs tierces sur iOS ne sont pas supportés et ne fonctionnent pas. Le support pourra être ajouté par la suite (<a href="https://github.com/mozilla/browserid/issues/1870" title="https://github.com/mozilla/browserid/issues/1870">Issue #1870</a>, <a href="https://github.com/mozilla/browserid/issues/2034" title="https://github.com/mozilla/browserid/issues/2034">Issue #2034</a>).</li>
</ul>
<h2 id="Other_Browsers">Autres Navigateurs</h2>
<p>Bien qu'ils ne soient pas explicitement supportés, un navigateur incluant les deux {{ domxref("window.postMessage()") }} et {{ domxref("Storage", "localStorage") }} devrait fonctionner. Ces APIs ont été rendues disponibles dans les principaux navigateurs depuis mars 2010.</p>
<h2 id="Known_Issues">Questions connues</h2>
<ul>
  <li>Les navigateurs doivent accepter les cookies tiers pour un bon fonctionnement (<a href="https://github.com/mozilla/browserid/issues/1352" title="https://github.com/mozilla/browserid/issues/1352">Issue #1352</a>).</li>
  <li>Les utilisateurs Android 2.x qui n'ont pas sélectionné de navigateur par défaut ne pourront pas se connecter (<a href="https://github.com/mozilla/browserid/issues/1854" title="https://github.com/mozilla/browserid/issues/1854">Issue #1854</a>).</li>
  <li>Quand l'émulation IE8 est forcée, Internet Explorer 9 peut échouer lors de la connection sur les sites.</li>
</ul>
Revenir à cette révision