mozilla
Vos résultats de recherche

    Compatibilité des navigateurs

    Persona est développé, testé, et supporté avec les navigateurs suivants. Grâce à la bibliothèque JavaScript inter-plateformes de Persona, les utilisateurs n'ont pas besoin de greffons pour utiliser Persona.

    Navigateurs pour ordinateur de bureau
    Internet Explorer 8.0*, 9.0, 10.0** (mais voir le mode de compatibilité ci-dessous)
    Firefox Versions courante, stable, Beta, Aurora, Nightly, et ESR.
    Précédente version stable
    Chrome Dernière version stable
    Safari Dernière version stable
    Opera Dernière version stable
    Navigateurs iOS
    Safari Mobile iOS 5.x — 6.x
    Navigateurs Android
    Navigateur par défaut 2.x — 4.x
    Firefox Versions stable courante, Beta, Aurora, et Nightly
    Précédente version stable
    Chrome Dernière version stable

    * : pour Windows XP.  : pour Windows Vista et Windows 7. ** : Windows 8.  : selon durée de vie.

    • Internet Explorer versions 6.0 et 7.0 non supportés. Les utilisateurs seront incités à mettre à jour leur navigateur.
    • Google Chrome Frame non supporté et ne fonctionne pas.
    • Les navigateurs tierces sur iOS ne sont pas supportés et ne fonctionnent pas. Le support pourra être ajouté par la suite (Issue #2034).

    Mode de compatibilité d'Internet Explorer

    À partir de la version 8.0, Internet Explorer supporte une fonctionnalité appelée Mode de compatibilité, dans lequel le navigateur peut être amené à émuler une version antérieure à la 8.0, en affichant la page. Cette fonctionnalité peut être contrôlée de trois façons différentes :

    • À travers un paramètre dans le navigateur ;
    • En se basant sur la présence et la valeur de la déclaration DOCTYPE de la page ;
    • À travers une instruction envoyée depuis le site, utilisant l'en-tête X-UA-Compatible, par un en-tête HTTP ou une balise <meta> dans la page. Cette méthode peut supplanter les deux autres.

    Parce que les versions Internet Explorer avant la 8.0 ne sont pas supportées par Persona, toute version d'Internet Explorer qui est configurée pour émuler une version antérieure à la 8.0, ne fonctionnera pas avec Persona.

    Autres navigateurs

    Bien qu'ils ne soient pas explicitement supportés, un navigateur incluant aussi bien window.postMessage() que localStorage devrait fonctionner. Ces API ont été rendues disponibles dans les principaux navigateurs depuis mars 2010.

    Problèmes connus

    • Les utilisateurs d'Android 2.x qui n'ont pas sélectionné de navigateur par défaut ne pourront pas se connecter (Issue #1854) ;
    • Les navigateurs doivent accepter les cookies tiers pour bénéficier de toutes les fonctionnalités (Issue #1352).

    Étiquettes et contributeurs liés au document

    Étiquettes : 
    Contributors to this page: Fredchat, Mylainos, MattouFP, sylvie, tregagnon
    Dernière mise à jour par : Fredchat,