Nos bénévoles n'ont pas encore traduit cet article en Français. Inscrivez-vous et aidez-nous à réaliser cette tâche !
Vous pouvez également lire cet article en English (US).

Warning: The latest specification does not include this interface anymore as the IDBDatabase.setVersion() method has been removed. See the compatibility table for version details.
The new way to do it is to use the IDBOpenDBRequest interface which has now the onblocked handler and the newly needed onupgradeneeded one.

The IDBVersionChangeRequest interface the IndexedDB API represents a request to change the version of a database. It is used only by the setVersion() method of IDBDatabase.

Methods

Inherits from: IDBRequest

IDBVersionChangeRequest.setVersion
Updates the version of the database. Returns immediately and runs a versionchange transaction on the connected database in a separate thread.

Attributes

Attribute Type Description
onblocked Function The event handler for the blocked event.

Browser compatibility

Update compatibility data on GitHub
DesktopMobile
ChromeEdgeFirefoxInternet ExplorerOperaSafariAndroid webviewChrome for AndroidEdge MobileFirefox for AndroidOpera for AndroidSafari on iOSSamsung Internet
Basic support
DeprecatedNon-standard
Chrome No support 12 — 23
Prefixed
No support 12 — 23
Prefixed
Prefixed Implemented with the vendor prefix: webkit
Edge ? Firefox No support NoIE No support NoOpera No support NoSafari No support NoWebView Android ? Chrome Android No support NoEdge Mobile ? Firefox Android No support NoOpera Android No support NoSafari iOS No support NoSamsung Internet Android No support No
setVersion
DeprecatedNon-standard
Chrome No support NoEdge No support NoFirefox No support NoIE No support NoOpera No support NoSafari No support NoWebView Android No support NoChrome Android No support NoEdge Mobile No support NoFirefox Android No support NoOpera Android No support NoSafari iOS No support NoSamsung Internet Android No support No

Legend

No support  
No support
Compatibility unknown  
Compatibility unknown
Non-standard. Expect poor cross-browser support.
Non-standard. Expect poor cross-browser support.
Deprecated. Not for use in new websites.
Deprecated. Not for use in new websites.
Requires a vendor prefix or different name for use.
Requires a vendor prefix or different name for use.

Étiquettes et contributeurs liés au document

Contributeurs à cette page : fscholz, inexorabletash, chrisdavidmills, teoli, nehasharma, grendel, jswisher
Dernière mise à jour par : fscholz,