IDBOpenDBRequest.onupgradeneeded

Nos bénévoles n'ont pas encore traduit cet article en Français. Inscrivez-vous et aidez-nous à réaliser cette tâche !
Vous pouvez également lire cet article en English (US).

The onupgradeneeded property of the IDBOpenDBRequest interface is the event handler for the upgradeneeded event, triggered when a database of a bigger version number than the existing stored database is loaded.

The event passed to the listener is an IDBVersionChangeEvent.

Inside the event handler function you can include code to upgrade the database structure, as shown in the example below.

Note: This feature is available in Web Workers.

Syntax

IDBOpenDBRequest.onupgradeneeded = function(event) { ... };

Example

In the following example you can see the onupgradeneeded handler being used to update the database structure if a database with a higher version number is loaded. For a full working example, see our To-do Notifications app (view example live.)

var db;

// Request version 3 of the database.
var request = window.indexedDB.open("library", 3);

// This event handles the event whereby a new version of the
// database needs to be created. Either one has not been created
// before, or a new version number has been submitted via the
// window.indexedDB.open line above.
request.onupgradeneeded = function(event) {
  db = request.result;
 
  db.onerror = function(errorEvent) {
    note.innerHTML += '<li>Error loading database.</li>';
  };

  if (event.oldVersion < 1) {
    // Version 1 is the first version of the database.
    var store = db.createObjectStore("books", {keyPath: "isbn"});
    var titleIndex = store.createIndex("by_title", "title", {unique: true});
    var authorIndex = store.createIndex("by_author", "author");
  }
  if (event.oldVersion < 2) {
    // Version 2 introduces a new index of books by year.
    var bookStore = request.transaction.objectStore("books");
    var yearIndex = bookStore.createIndex("by_year", "year");
  }
  if (event.oldVersion < 3) {
    // Version 3 introduces a new object store for magazines with two indexes.
    var magazines = db.createObjectStore("magazines");
    var publisherIndex = magazines.createIndex("by_publisher", "publisher");
    var frequencyIndex = magazines.createIndex("by_frequency", "frequency");
  }
};

request.onerror = function(event) {
  note.innerHTML += '<li>Error loading database.</li>';
};

request.onsuccess = function(event) {
  note.innerHTML += '<li>Database initialised.</li>';
  db = request.result;
  populateAndDisplayData();
};

Specifications

Specification Status Comment
Indexed Database API
The definition of 'onupgradeneeded' in that specification.
Recommendation  
Indexed Database API 2.0
The definition of 'onupgradeneeded' in that specification.
Editor's Draft  

Browser compatibility

Feature Chrome Edge Firefox (Gecko) Internet Explorer Opera Safari (WebKit)
Basic support 23webkit
24 (unprefixed)
(Yes) 10 moz
16.0 (16.0)
10, partial 15 7.1
Available in workers (Yes) ? 37.0 (37.0) ? (Yes) ?
Indexed Database 2.0 58 ? ? ? 45 ?
Feature Android Webview Chrome for Android Edge Firefox Mobile (Gecko) Firefox OS IE Phone Opera Mobile Safari Mobile
Basic support (Yes) (Yes) (Yes) 22.0 (22.0) 1.0.1 10 22 8
Available in workers (Yes) (Yes) ? 37.0 (37.0) (Yes) ? (Yes) ?
Indexed Database 2.0 58 58 ? ? ? ? 45 ?

See also

Étiquettes et contributeurs liés au document

 Contributeurs à cette page : lukaselmer, jpmedley, libbymc, chrisdavidmills, teoli, freaktechnik, fscholz
 Dernière mise à jour par : lukaselmer,