Construire d'anciennes branches

Les anciennes branches de Firefox OS nécessitent la présence des paquets multi-architectures. Ils ne sont pas installés par défaut sur les systèmes d'exploitation récents. 

Lancez ces commandes pour permettre l'utilisation de l'architecture i386 :

sudo dpkg --add-architecture i386
sudo apt-get update

Exécutez cette commande pour installer les paquets nécessaires :

sudo apt-get install --no-install-recommends autoconf2.13 bison bzip2 ccache curl flex gawk gcc g++ g++-multilib gcc-4.7 g++-4.7 g++-4.7-multilib git lib32ncurses5-dev lib32z1-dev libgconf2-dev zlib1g:amd64 zlib1g-dev:amd64 zlib1g:i386 zlib1g-dev:i386 libgl1-mesa-dev libx11-dev make zip ia32-libs libxml2-utils lzop openjdk-7-jdk

Utilisez ces commandes pour faire de gcc-4.7 le compilateur par défaut :

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 1 
sudo update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-4.7 1 
sudo update-alternatives --set gcc "/usr/bin/gcc-4.7" 
sudo update-alternatives --set g++ "/usr/bin/g++-4.7"

Étiquettes et contributeurs liés au document

 Contributeurs à cette page : jwhitlock, xdelatour
 Dernière mise à jour par : jwhitlock,