Compare Revisions

Signing a XPI

Revision 385359:

Revision 385359 by jswisher on

Revision 424145:

Revision 424145 by kmaglione on

Title:
Signing a XPI
Signing a XPI
Slug:
Signing_a_XPI
Signing_a_XPI
Tags:
"NeedsMarkupWork","Extensions","Add-ons","NeedsHelp","XPInstall","Code snippets"
"NeedsMarkupWork","Extensions","Add-ons","NeedsHelp","XPInstall","Code snippets"
Content:

Revision 385359
Revision 424145
t231      <strong>Warning:</strong> Currently FireFox expects XPI filt231      <strong>Warning:</strong> Currently Firefox expects XPI fil
>es to be signed with certificates that conform to the older Objec>es to be signed with certificates that conform to the older Objec
>t Signing convention, rather than the newer Code Signing conventi>t Signing convention, rather than the newer Code Signing conventi
>on. This means that Firefox will refuse to install code signed vi>on. This means that Firefox will refuse to install code signed vi
>a an intermediate certificate authority such as <strong>Certum Le>a an intermediate certificate authority such as <strong>Certum Le
>vel I</strong> unless the user installs that intermediate CA cert>vel I</strong> unless the user installs that intermediate CA cert
>ificate into Firefox first. Installing the intermediate CA certif>ificate into Firefox first. Installing the intermediate CA certif
>icate causes Firefox to mark the intermediate Code Signing CA cer>icate causes Firefox to mark the intermediate Code Signing CA cer
>tificate as a valid Object Signing CA certificate, which makes it>tificate as a valid Object Signing CA certificate, which makes it
> all work. {{ Bug(321156) }} has been filed to request a way to o> all work. {{ Bug(321156) }} has been filed to request a way to o
>bviate the installation of intermediate Code Signing CA certs int>bviate the installation of intermediate Code Signing CA certs int
>o Firefox.>o Firefox.

Back to History