mozilla

Compare Revisions

Safely accessing content DOM from chrome

Change Revisions

Revision 98882:

Revision 98882 by Jesse on

Revision 98883:

Revision 98883 by Jesse on

Title:
Safely accessing content DOM from chrome
Safely accessing content DOM from chrome
Slug:
Safely_accessing_content_DOM_from_chrome
Safely_accessing_content_DOM_from_chrome
Tags:
DOM, Extensions, Add-ons, Security, XPCNativeWrapper
DOM, Extensions, Add-ons, Security, XPCNativeWrapper
Content:

Revision 98882
Revision 98883
t111      BAD in <em>all</em> versions. Some developers have, in the t111      BAD in <em>all</em> versions. Some developers have, in the 
>past, used an ill-advised trick. Script can override <code>getSel>past, used this ill-advised trick. Script can override <code>getS
>ection</code> in older versions <em>and</em> this doesn't work at>election</code> in older versions <em>and</em> this doesn't work 
> all in Firefox 1.0.3 and Mozilla 1.7.7:>at all in Firefox 1.0.3 and Mozilla 1.7.7:

Back to History