mozilla
Your Search Results

    Thunderbird Configuration Files

    This article is in need of a technical review.

    Warning: The content of this article may be out of date. It was imported from mozilla.org.



    This page has been flagged by editors or users as needing technical review. Until it is fully reviewed, it may contain inaccurate or incorrect information.

    Config Editor

    Many of the tips and tricks mentioned on this site can be applied by using the built-in Config Editor. To access the Config Editor, go to Tools > Options... (Thunderbird > Preferences... on Mac OS X, and Edit > Preferences... on Linux), select the Advanced options panel, click on the General tab, and click on Config Editor. This will display a list of used preferences, as well as a search bar at the top.

    Double-click on a preference to change its value. To do add a new preference, open the context menu (right-click) on any existing preference, go to the New menu, and select the type of preference.

    Some preferences may require that you restart Thunderbird in order to take effect.

    Configuration Files

    Some tips and tricks require that you edit configuration files manually. There are three files you should know about:

    userChrome.css
    Used to change the appearance of the browser.
    userContent.css
    Used to change the appearance of web pages.
    user.js
    Used to change various preferences.

    All these files are plain text files you need to create in your profile folder and can be edited using a standard text editor, such as Notepad on Windows and gedit or kate on Linux.

    Locate your profile folder

    Before the configuration files are presented, you should know how to find your profile folder, which is where Thunderbird saves all your settings on your hard drive.

    • On Windows Vista/XP/2000, the path is usually %AppData%\Thunderbird\Profiles\xxxxxxxx.default\, where xxxxxxxx is a random string of 8 characters. Just browse to C:\Documents and Settings\[User Name]\Application Data\Thunderbird\Profiles\ on Windows XP/2000 or C:\users\[User Name]\AppData\Roaming\Thunderbird\Profiles\ on Windows Vista, and the rest should be obvious.
    • On Windows 95/98/Me, the path is usually C:\WINDOWS\Application Data\Thunderbird\Profiles\xxxxxxxx.default\
    • On Linux, the path is usually ~/.thunderbird/xxxxxxxx.default/
    • On Mac OS X, the path is usually ~/Library/Thunderbird/Profiles/xxxxxxxx.default/

    %AppData% is a shorthand for the Application Data path on Windows 2000/XP/Vista. To use it, click Start > Run... (use the search box on Vista), enter %AppData% and press Enter. You will be taken to the "real" folder, which is normally C:\Documents and Settings\[User Name]\Application Data on Windows XP/2000, C:\users\[User Name]\AppData\Roaming on Windows Vista.

    Thunderbird is capable of handling more than one user and thus, more than one profile. The path examples above refers to the default profile that is automatically created when you start Thunderbird for the first time. You can manage any number of profiles by using the Profile Manager.

    userChrome.css

    This file sets the display rules for various elements in the Thunderbird user interface and is located in the sub-folder called chrome in your profile folder. This folder does not exist by default, so you need to create it before you can start adding your preferences.

    userContent.css

    This file sets the display rules for web content and is located in the sub-folder called chrome in your profile folder. As with userChrome.css, this folder does not exist by default, so you need to create it before you can start adding your preferences.

    user.js

    This is the additional preferences file for Thunderbird and is located in your profile folder. The file does not exist by default, so you need to create it before you can start adding your preferences. In almost all cases, edits made using the user.js can be done via the Config Editor, which is the recommended method.

    Windows users: If you know how to create a file, just skip this section. Before you can create the file, you must make sure that you can see the file type extensions in Windows. Start Explorer (just click on the My Computer icon on your desktop) and select Tools > Folder Options.... Click the View tab and uncheck the Hide extensions for known file types option. Now, go to your profile folder and select File > New > Text Document. The default name New Text Document.txt should be displayed. Change the name to user.js (click Yes on the file type warning that appears).

    Linux users: I assume that you know how to create a file if you're running Linux. Just create user.js in your profile folder.

    Document Tags and Contributors

    Contributors to this page: jenzed, Anke77, chrisdavidmills
    Last updated by: Anke77,