Advanced Linux Sound Architecture (known by the acronym ALSA) is a Linux kernel component intended to replace the original Open Sound System (OSS) for providing device drivers for sound cards.

For more information on ALSA, visit

If you get the following error while building Firefox on Linux, it means a few library files required for ogg or wave support are missing.

checking for snd_pcm_open in -lasound... no
configure: error: Ogg or Wave support on Linux requires the alsa library

Issue Resolution

Disable OGG and Wave Support

You can append the following lines to your .mozconfig:

ac_add_options --disable-ogg
ac_add_options --disable-wave

Get OGG Support

If you want OGG support install alsa development library.

On Ubuntu:

sudo apt-get install libasound2-dev

Document Tags and Contributors

 Contributors to this page: teoli, Taken, paritosh1010, Sheppy
 Last updated by: Taken,