Debugging on Mac OS X

  • Revision slug: Debugging_on_Mac_OS_X
  • Revision title: Debugging on Mac OS X
  • Revision id: 55349
  • Created:
  • Creator: Jonathan_Watt
  • Is current revision? No
  • Comment NO_EM_RESTART died a long time ago; 1 words added, 41 words removed

Revision Content

This document explains how to debug Mozilla-derived applications such as Firefox, Thunderbird and SeaMonkey on Mac OS X using Xcode. For specific information on a way to debug hangs, see Debugging a hang on OS X.

Requirements

See the Mac OS X build requirements.

Creating the project in Xcode (up to v3)

Xcode is Apple's set of developer tools and IDE, shipping with the system as of Mac OS X 10.3.

  1. Open Xcode, and create a new Project with File > New Project. In the list, choose "Empty Project" as the project type, click Next, name the project and choose where to save the project, then click Finish.
  2. Now you need to add the executable. Select Project > New Custom Executable and type a pretty name, then click the Choose button to locate the .app file that you want to debug (Mozilla.app, Firefox.app, DeerParkDebug.app etc). The .app file is typically found inside the "dist" folder in your build directory. Do not click Finish yet!
  3. Important! - Older versions of Xcode won't make your life that easy; there is still one vital step to be done if you aren't using XCode 3 or higher. You must manually locate the executable binary inside the application bundle, and edit the path to that. In other words, the value of the Executable Path text field should look something like this: " ~/builds/mozilla/dist/DeerParkDebug.app/Contents/MacOS/firefox-bin" (Make sure to select the "-bin" file, the non-"-bin" is just a launch script.)
  4. Now click Finish. An entry with the pretty name you entered in the previous dialog will appear under the "Executables" branch of the "Groups & Files" pane in the Xcode Project window.
  5. In order for Xcode to know what sources you want to debug, you need to tell it where to find them. Go to Project > Edit Active Executable, click the Debugging tab, and finally drag your top-level mozilla/ directory to the panel "Additional folders to find source files in".
  6. Still in "Edit Active Executable", go to the panel titled "Arguments". Add "-P profilename" where profilename is the name of your debugging Firefox profile to the argument list.
  7. Go to Xcode > Preferences. Find the Debugging preferences pane, and make sure "Load symbols lazily" is unchecked.
  8. Finally, if you are debugging Firefox, Thunderbird or some other application that supports multiple profiles, using a separate profile for debugging purposes is recommended. See "Having a profile for debugging purposes" below.

Creating the project in Xcode v4

Apple changed a lot of things in Xcode 4 (Mac OS X 10.6/10.7)

  1. Open Xcode, and create a new Project with File > New Project. Under the Mac OS X list (not the iOS list, if present), select the "Other" template group and choose "Empty Project" as the project type, click Next, name the project and choose where to save the project, then click Create.
  2. In the Product menu, select "New Scheme" and name your scheme. After you click OK, Xcode should open the settings window for the new scheme. If not, then open its settings from the Product > Edit Scheme menu.
  3. Select "Run" on the left-hand side of the settings window, then select the "Info" tab. Set the Executable by clicking on "None" and selecting "Other...". A new dialog titled "Choose an executable to launch" will pop up. Browse to the .app file that you want to debug (Mozilla.app, Firefox.app, DeerParkDebug.app etc). The .app file is typically found inside the "dist" folder in your build directory.
  4. If you are debugging Firefox, Thunderbird or some other application that supports multiple profiles, using a separate profile for debugging purposes is recommended. See "Having a profile for debugging purposes" below. Select the "Arguments" tab in the scheme editor, and click the '+' below the "Arguments passed on launch" field. Add "-P profilename", where profilename is the name of a profile you created previously.
  5. Also in the "Arguments" panel, you may want to add an environment variable "MOZ_QUIET" with value 1 to suppress the noisy ++DOMWINDOW debug output.
  6. Select "Build" from the left of the scheme editor window, and check that there is nothing listed under Targets (otherwise it may cause problems when you try to run the executable for debugging since you will get build errors).
  7. Click OK to close the scheme editor.
  8. At this point you can run the application, and it should show you source files when you pause or hit breakpoints, but it doesn't automatically pick up your source tree.
  9. In order for Xcode to know what sources you want to debug, you need to tell it where to find them. In the File menu choose 'Add Files to "your-project"'. Browse to your source tree and either command-click the set of directories you care about, or just select the whole tree. Xcode will import everything, including .hg directories, so you will need to remove them from your project after the import. The amount of work to carefully select which source files to import doesn't seem to be much different than the effort to clean up after importing everything.

Starting a debug session

Xcode 3

When you have created a project file, simply use the menu item Debug > Debug Executable, or change to the debug view by clicking the debug button (typically the third one from the left), and click "Debug".

Xcode 4

Make sure breakpoints are active (which implies running under the debugger) by opening the Product menu and selecting "Debug / Activate Breakpoints" (also shown by the "Breakpoints" button in the top right section of the main window). Then click the "Run" button or select "Run" from the Product menu.

Setting breakpoints

Setting a breakpoint is easy. Just open the source file you want to debug in Xcode, and click in the margin to the left of the line of code where you want to break.

During the debugging session, each time that line is executed, the debugger will break there, and you will be able to debug it.

Having a profile for debugging purposes

It is recommended to create a separate profile to debug with, whatever your task, so that you don't lose precious data like Bookmarks, saved passwords, etc. So that you're not bothered with the profile manager every time you start to debug, expand the "Executables" branch of the "Groups & Files" list and double click on the Executable you added for Mozilla. Click the plus icon under the "Arguments" list and type "-P <profile name>" (e.g. "-P MozillaDebug"). Close the window when you're done.

Looking at variables

Printing out information in realtime about "native" Objective-C objects is simple. For example, if there's an NSString named 'myString' that you want to get the contents of, you can use the print-object (or short: po) command.

(gdb) po myString
'This is the contents of the string'

Below are instructions for how to deal with C++ objects, such as when debugging code written in XPCOM.

If you've used a debugger before, this is pretty simple. There are two things that should be pointed out, though.

First, when looking at variables that are C++ classes, Xcode separates the protected/private members into their own sub-hierarchy called protected and private, respectively. It will also group inherited member variables into a sub-hierarchy named by the parent class. If you don't see the member variable you're looking for, make sure that you drill down all the way.

If you want to save yourself the hassle of flipping down many little triangles, you can display a variable on the console using

(gdb) p variable_name

Pointer types aren't automatically dereferenced so you may need to do that in the command. It will write out a fully expanded representation to the console. This representation is extremely customizable with various set print feature-name commands. See the gdb doc.

 

See Debugging Mozilla with gdb for non-Mac-specific information about using gdb.

 

Debugging from the Terminal with gdb

Debugging from within Xcode (see above) is much easier, but debugging with gdb in the Terminal is also possible.

1. cd into your Mozilla application (.app) bundle. As an example, we'll use a Firefox debug build.

% cd dist/DeerParkDebug.app/Contents/MacOS 

2. Set the DYLD_LIBRARY_PATH environment variable to tell the loader that this is where all the shared libraries are

% export DYLD_LIBRARY_PATH=`pwd`

3. Debug

% cd ../../.. 
% gdb ./firefox-bin

Other Resources

Apple has an extensive list of debugging tips and techniques at https://developer.apple.com/library/mac/#technotes/tn2124/_index.html.

Questions? Problems?

Try asking nicely in our IRC channel #developers. Often many Mac developers usually hang out in the #camino or #macdev channels.


Original version by Mike Pinkerton (mailto:pinkerton@netscape.com), migrated by Brian Ray (mailto:bray@sent.com). Updated to the new Xcode world and maintained by Håkan Waara (mailto:hwaara@gmail.com).

Revision Source

<p>This document explains how to debug Mozilla-derived applications such as Firefox, Thunderbird and SeaMonkey on Mac OS X using Xcode. For specific information on a way to debug hangs, see <a href="/en/Debugging_a_hang_on_OS_X" title="en/Debugging_a_hang_on_OS_X">Debugging a hang on OS X</a>.</p>
<h3 name="Requirements">Requirements</h3>
<p>See the <a href="/En/Developer_Guide/Build_Instructions/Mac_OS_X_Prerequisites" title="En/Developer_Guide/Build_Instructions/Mac_OS_X_Prerequisites">Mac OS X build requirements</a>.</p>
<h3 name="Creating_the_project_in_Xcode">Creating the project in Xcode (up to v3)</h3>
<p>Xcode is Apple's set of developer tools and IDE, shipping with the system as of Mac OS X 10.3.</p>
<ol> <li>Open Xcode, and create a new Project with File &gt; New Project. In the list, choose "Empty Project" as the project type, click Next, name the project and choose where to save the project, then click Finish.</li> <li>Now you need to add the executable. Select Project &gt; New Custom Executable and type a pretty name, then click the Choose button to locate the .app file that you want to debug (Mozilla.app, Firefox.app, DeerParkDebug.app etc). The .app file is typically found inside the "dist" folder in your build directory. Do not click Finish yet!</li> <li><strong>Important!</strong> - Older versions of Xcode won't make your life <em>that</em> easy; there is still one vital step to be done if you aren't using XCode 3 or higher. You must manually locate the executable binary inside the application bundle, and edit the path to that. In other words, the value of the Executable Path text field should look something like this: " ~/builds/mozilla/dist/DeerParkDebug.app/Contents/MacOS/firefox-bin" (Make sure to select the "-bin" file, the non-"-bin" is just a launch script.)</li> <li>Now click Finish. An entry with the pretty name you entered in the previous dialog will appear under the "Executables" branch of the "Groups &amp; Files" pane in the Xcode Project window.</li> <li>In order for Xcode to know what sources you want to debug, you need to tell it where to find them. Go to Project &gt; Edit Active Executable, click the Debugging tab, and finally drag your top-level mozilla/ directory to the panel "Additional folders to find source files in".</li> <li>Still in "Edit Active Executable", go to the panel titled "Arguments". Add "-P <var>profilename</var>" where <var>profilename</var> is the name of your debugging Firefox profile to the argument list.</li> <li>Go to Xcode &gt; Preferences. Find the Debugging preferences pane, and make sure "Load symbols lazily" is <em>unchecked</em>.</li> <li>Finally, if you are debugging Firefox, Thunderbird or some other application that supports multiple profiles, using a separate profile for debugging purposes is recommended. See "Having a profile for debugging purposes" below.</li>
</ol>
<h3 name="Creating_the_project_in_Xcode">Creating the project in Xcode v4</h3>
<p>Apple changed a lot of things in Xcode 4 (Mac OS X 10.6/10.7)</p>
<ol> <li>Open Xcode, and create a new Project with File &gt; New Project. Under the Mac OS X list (not the iOS list, if present), select the "Other" template group and choose "Empty Project" as the project type, click Next, name the project and choose where to save the project, then click Create.</li> <li>In the Product menu, select "New Scheme" and name your scheme. After you click OK, Xcode should open the settings window for the new scheme. If not, then open its settings from the Product &gt; Edit Scheme menu.</li> <li>Select "Run" on the left-hand side of the settings window, then select the "Info" tab. Set the Executable by clicking on "None" and selecting "Other...". A new dialog titled "Choose an executable to launch" will pop up. Browse to the .app file that you want to debug (Mozilla.app, Firefox.app, DeerParkDebug.app etc). The .app file is typically found inside the "dist" folder in your build directory.</li> <li>If you are debugging Firefox, Thunderbird or some other application that supports multiple profiles, using a separate profile for debugging purposes is recommended. See "Having a profile for debugging purposes" below. Select the "Arguments" tab in the scheme editor, and click the '+' below the "Arguments passed on launch" field. Add "-P <em>profilename</em>", where <em>profilename</em> is the name of a profile you created previously.</li> <li>Also in the "Arguments" panel, you may want to add an environment variable "MOZ_QUIET" with value 1 to suppress the noisy ++DOMWINDOW debug output.</li> <li>Select "Build" from the left of the scheme editor window, and check that there is nothing listed under Targets (otherwise it may cause problems when you try to run the executable for debugging since you will get build errors).</li> <li>Click OK to close the scheme editor.</li> <li>At this point you can run the application, and it should show you source files when you pause or hit breakpoints, but it doesn't automatically pick up your source tree.</li> <li>In order for Xcode to know what sources you want to debug, you need to tell it where to find them. In the File menu choose 'Add Files to <span style="font-style: italic;">"</span><em>your-project</em>"'. Browse to your source tree and either command-click the set of directories you care about, or just select the whole tree. Xcode will import everything, including .hg directories, so you will need to remove them from your project after the import. The amount of work to carefully select which source files to import doesn't seem to be much different than the effort to clean up after importing everything.</li>
</ol>
<h3 name="Starting_a_debug_session">Starting a debug session</h3>
<h4>Xcode 3</h4>
<p>When you have created a project file, simply use the menu item Debug &gt; Debug Executable, or change to the debug view by clicking the debug button (typically the third one from the left), and click "Debug".</p>
<h4>Xcode 4</h4>
<p>Make sure breakpoints are active (which implies running under the debugger) by opening the Product menu and selecting "Debug / Activate Breakpoints" (also shown by the "Breakpoints" button in the top right section of the main window). Then click the "Run" button or select "Run" from the Product menu.</p>
<h3 name="Setting_breakpoints">Setting breakpoints</h3>
<p>Setting a breakpoint is easy. Just open the source file you want to debug in Xcode, and click in the margin to the left of the line of code where you want to break.</p>
<p>During the debugging session, each time that line is executed, the debugger will break there, and you will be able to debug it.</p>
<h3 name="Having_a_profile_for_debugging_purposes">Having a profile for debugging purposes</h3>
<p>It is recommended to create a separate profile to debug with, whatever your task, so that you don't lose precious data like Bookmarks, saved passwords, etc. So that you're not bothered with the profile manager every time you start to debug, expand the "Executables" branch of the "Groups &amp; Files" list and double click on the Executable you added for Mozilla. Click the plus icon under the "Arguments" list and type "-P &lt;profile name&gt;" (e.g. "-P MozillaDebug"). Close the window when you're done.</p>
<h3 name="Looking_at_variables">Looking at variables</h3>
<p>Printing out information in realtime about "native" Objective-C objects is simple. For example, if there's an NSString named 'myString' that you want to get the contents of, you can use the print-object (or short: po) command.</p>
<pre class="eval">(gdb) po myString
'This is the contents of the string'
</pre>
<p>Below are instructions for how to deal with C++ objects, such as when debugging code written in XPCOM.</p>
<p>If you've used a debugger before, this is pretty simple. There are two things that should be pointed out, though.</p>
<p>First, when looking at variables that are C++ classes, Xcode separates the protected/private members into their own sub-hierarchy called <strong>protected</strong> and <strong>private</strong>, respectively. It will also group inherited member variables into a sub-hierarchy named by the parent class. If you don't see the member variable you're looking for, make sure that you drill down all the way.</p>
<p>If you want to save yourself the hassle of flipping down many little triangles, you can display a variable on the console using</p>
<pre class="eval">(gdb) p variable_name
</pre>
<p>Pointer types aren't automatically dereferenced so you may need to do that in the command. It will write out a fully expanded representation to the console. This representation is extremely customizable with various <strong>set print feature-name</strong> commands. See the gdb doc.</p>
<p> </p>
<p>See <a class="internal" href="/en/Debugging_Mozilla_with_gdb" title="en/Debugging Mozilla with gdb">Debugging Mozilla with gdb</a> for non-Mac-specific information about using gdb.</p>
<p> </p>
<h3 name="Debugging_from_the_Terminal_with_gdb">Debugging from the Terminal with gdb</h3>
<p>Debugging from within Xcode (see above) is much easier, but debugging with gdb in the Terminal is also possible.</p>
<p>1. cd into your Mozilla application (.app) bundle. As an example, we'll use a Firefox debug build.</p>
<pre class="eval">% cd dist/DeerParkDebug.app/Contents/MacOS 
</pre>
<p>2. Set the DYLD_LIBRARY_PATH environment variable to tell the loader that this is where all the shared libraries are</p>
<pre class="eval">% export DYLD_LIBRARY_PATH=`pwd`
</pre>
<p>3. Debug</p>
<pre class="eval">% cd ../../.. 
% gdb ./firefox-bin
</pre>
<h3 name="Questions.3F_Problems.3F">Other Resources</h3>
<p>Apple has an extensive list of debugging tips and techniques at <a class="link-https" href="https://developer.apple.com/library/mac/#technotes/tn2124/_index.html" title="https://developer.apple.com/library/mac/#technotes/tn2124/_index.html">https://developer.apple.com/library/mac/#technotes/tn2124/_index.html</a>.</p>
<h3 name="Questions.3F_Problems.3F">Questions? Problems?</h3>
<p>Try asking nicely in our IRC channel <a class="link-irc" href="irc://irc.mozilla.org/developers">#developers</a>. Often many Mac developers usually hang out in the <a class="link-irc" href="irc://irc.mozilla.org/camino">#camino</a> or <a class="link-irc" href="irc://irc.mozilla.org/macdev">#macdev</a> channels.</p>
<hr>
<p>Original version by Mike Pinkerton (<a class="link-mailto" href="mailto:pinkerton@netscape.com">mailto:pinkerton@netscape.com</a>), migrated by Brian Ray (<a class="link-mailto" href="mailto:bray@sent.com">mailto:bray@sent.com</a>). Updated to the new Xcode world and maintained by Håkan Waara (<a class="link-mailto" href="mailto:hwaara@gmail.com">mailto:hwaara@gmail.com</a>).</p>
Revert to this revision