mozilla

Compare Revisions

Chrome registration

Change Revisions

Revision 477547:

Revision 477547 by kscarfone on

Revision 493315:

Revision 493315 by kscarfone on

Title:
Chrome registration
Chrome registration
Slug:
Chrome_Registration
Chrome_Registration
Tags:
"Référence", "Reference", "Toolkit API", "NeedsHelp"
"Référence", "Reference", "Toolkit API", "NeedsHelp"
Content:

Revision 477547
Revision 493315
n16    <div class="geckoVersionNote">n16    <div class="note">
17      <p>
18        {{ gecko_callout_heading("2.0") }}
19      </p>17      <p>
20      <p>
21        With Gecko 1.9.2 and older, Mozilla reads <code>chrome/*.18        <strong>Note:</strong> With {{Gecko("1.9.2")}} and older,
>manifest</code> files from applications. Starting with Gecko 2.0 > Mozilla reads <code>chrome/*.manifest</code> files from applicat
>{{ geckoRelease("2.0") }}, the root <code>chrome.manifest</code> >ions. Starting with {{Gecko("2.0")}}, the root <code>chrome.manif
>is the only manifest used; you can add <a href="/en/Chrome_Regist>est</code> is the only manifest used; you can add <a href="/en/Ch
>ration#manifest" title="en/Chrome Registration#manifest"><code>ma>rome_Registration#manifest" title="en/Chrome Registration#manifes
>nifest</code></a> commands to that file to load secondary manifes>t"><code>manifest</code></a> commands to that file to load second
>ts.>ary manifests.
n219      Note that only stylesheets at chrome URIs can be applied inn216      <strong>Note:</strong> Only stylesheets at chrome URIs can 
> this way.>be applied in this way.
n235        There was a bug in Gecko 1.8.1.5 (Firefox 2.0.0.5) and ean232        <strong>Note:</strong> There was a bug in {{Gecko("1.8.1.
>rlier where you could not use a relative URL for the <em>new-reso>5")}} (Firefox 2.0.0.5) and earlier where you could not use a rel
>lved-URI</em> parameter. You needed to provide an absolute URL. S>ative URL for the <em>new-resolved-URI</em> parameter. You needed
>ee {{ Bug(323455) }}.> to provide an absolute URL. See {{ Bug(323455) }}.
n255        Note that there are no security restrictions preventing wn252        <strong>Note:</strong> There are no security restrictions
>eb content from including content at resource: URIs, so take care> preventing web content from including content at resource: URIs,
> what you make visible there.> so take care what you make visible there.
n302        Versions of Gecko before 1.8.0.13 and 1.8.1.5 contained an299        <strong>Note:</strong> Versions of Gecko before {{Gecko("
> bug where if you use the comparisons &lt;, &gt; or =, the versio>1.8.0.13")}} and {{Gecko("1.8.1.5")}} contained a bug where if yo
>n string had be two or more characters long. If not, you would ge>u use the comparisons &lt;, &gt; or =, the version string had be 
>t a message in the error console that the <code>appversion</code>>two or more characters long. If not, you would get a message in t
> flag was not recognized. See {{ Bug(380398) }}.>he error console that the <code>appversion</code> flag was not re
 >cognized. See {{ Bug(380398) }}.
t399    <div class="geckoVersionNote">t396    <div class="note">
400      <p>
401        {{ gecko_callout_heading("2.0") }}
402      </p>397      <p>
403      <p>
404        Support for this flag has been removed in Gecko 2.0 {{ ge398        <strong>Note:</strong> Support for this flag has been rem
>ckoRelease("2.0") }}. You can no longer disable <code>XPCNativeWr>oved in {{Gecko("2.0")}}. You can no longer disable <code>XPCNati
>apper</code>s. To update your add-on to work without this flag:>veWrapper</code>s. To update your add-on to work without this fla
 >g:

Back to History