mozilla

Revision 129123 of ALSA

  • Revision slug: Alsa
  • Revision title: ALSA
  • Revision id: 129123
  • Created:
  • Creator: Taken
  • Is current revision? Yes
  • Comment some clean up; 4 words added, 4 words removed

Revision Content

Advanced Linux Sound Architecture (known by the acronym ALSA) is a Linux kernel component intended to replace the original Open Sound System (OSS) for providing device drivers for sound cards.

For more information on ALSA, visit http://en.wikipedia.org/wiki/Advance...d_Architecture.

If you get the following error while building Firefox on Linux, it means a few library files required for ogg or wave support are missing.

checking for snd_pcm_open in -lasound... no
configure: error: Ogg or Wave support on Linux requires the alsa library

Issue Resolution

Disable OGG and Wave Support

You can append the following lines to your .mozconfig:

ac_add_options --disable-ogg
ac_add_options --disable-wave

Get OGG Support

If you want OGG support install alsa development library.

On Ubuntu:

sudo apt-get install libasound2-dev

Revision Source

<p><strong>Advanced Linux Sound Architecture</strong> (known by the acronym <strong>ALSA</strong>) is a Linux kernel component intended to replace the original Open Sound System (OSS) for providing device drivers for sound cards.</p>
<p>For more information on ALSA, visit <a class=" external" href="http://en.wikipedia.org/wiki/Advanced_Linux_Sound_Architecture" rel="freelink">http://en.wikipedia.org/wiki/Advance...d_Architecture</a>.</p>
<p>If you get the following error while building Firefox on Linux, it means a few library files required for ogg or wave support are missing.</p>
<pre>checking for snd_pcm_open in -lasound... no
configure: error: Ogg or Wave support on Linux requires the alsa library
</pre>
<h2 id="Issue_Resolution">Issue Resolution</h2>
<h3 id="Disable_OGG_and_Wave_Support">Disable OGG and Wave Support</h3>
<p>You can append the following lines to your .mozconfig:</p>
<pre>ac_add_options --disable-ogg
ac_add_options --disable-wave
</pre>
<h3 id="Get_OGG_Support">Get OGG Support</h3>
<p>If you want OGG support install alsa development library.</p>
<p>On Ubuntu:</p>
<pre><code>sudo apt-get install libasound2-dev</code></pre>
Revert to this revision