MDN may have intermittent access issues April 18 13:00 - April 19 01:00 UTC. See whistlepig.mozilla.org for all notifications.

mozilla

Compare Revisions

Firefox OS build prerequisites

Change Revisions

Revision 440575:

Revision 440575 by tlatsas on

Revision 440581:

Revision 440581 by tlatsas on

Title:
Firefox OS build prerequisites
Firefox OS build prerequisites
Slug:
Mozilla/Firefox_OS/Firefox_OS_build_prerequisites
Mozilla/Firefox_OS/Firefox_OS_build_prerequisites
Tags:
"Mobile", "B2G", "Firefox OS", "Build documentation"
"Mobile", "B2G", "Firefox OS", "Build documentation"
Content:

Revision 440575
Revision 440581
t274      By default, Arch Linux uses Python3. You'll have to force it274      By default, Arch Linux uses Python3. You'll have to force i
>t to use the old python2:>t to use the old python2. You can do that by linking the python2 
 >executable to python but this is discouraged and considered error
 >-prone. This will also break python 3 if it is installed on your 
 >system. A better way is to use virtualenv/virtualenvwrapper:
275    </p>
276    <pre>275    </p>
277<span style=""><span style="">$ cd /usr/bin</span></span>276    <pre>
278 277<span style=""><span style="">$ sudo pacman -S python-virtualenvw
 >rapper
279<span style=""><span style="">$ sudo ln -fs python2 python</span>278$ </span></span>source /usr/bin/virtualenvwrapper.sh
></span> 
279$ mkvirtualenv -p `which python2` firefoxos
280$ workon firefoxos

Back to History