mozilla

Revision 509069 of Low-Level APIs

  • Revision slug: Mozilla/Add-ons/SDK/Low-Level_APIs
  • Revision title: Low-Level APIs
  • Revision id: 509069
  • Created:
  • Creator: wbamberg
  • Is current revision? No
  • Comment

Revision Content

Modules in this section implement low-level APIs. These modules fall roughly into three categories:

  • fundamental utilities such as collection and url. Many add-ons are likely to want to use modules from this category.

  • building blocks for higher level modules, such as events, worker, and api-utils. You're more likely to use these if you are building your own modules that implement new APIs, thus extending the SDK itself.

  • privileged modules that expose powerful low-level capabilities such as window/utils and xhr. You can use these modules in your add-on if you need to, but should be aware that the cost of privileged access is the need to take more elaborate security precautions. In many cases these modules have simpler, more restricted analogs among the "High-Level APIs" (for example, windows or request).

These modules are still in active development, and we expect to make incompatible changes to them in future releases.

{{ LandingPageListSubpages ("/en-US/Add-ons/SDK/Low-Level_APIs", 5) }}

 

Revision Source

<p>Modules in this section implement low-level APIs. These modules fall roughly into three categories:</p>
<ul>
 <li>
  <p>fundamental utilities such as <a>collection</a> and <a>url</a>. Many add-ons are likely to want to use modules from this category.</p>
 </li>
 <li>
  <p>building blocks for higher level modules, such as <a>events</a>, <a>worker</a>, and <a>api-utils</a>. You're more likely to use these if you are building your own modules that implement new APIs, thus extending the SDK itself.</p>
 </li>
 <li>
  <p>privileged modules that expose powerful low-level capabilities such as <a>window/utils</a> and <a>xhr</a>. You can use these modules in your add-on if you need to, but should be aware that the cost of privileged access is the need to take more elaborate security precautions. In many cases these modules have simpler, more restricted analogs among the "High-Level APIs" (for example, <a>windows</a> or <a>request</a>).</p>
 </li>
</ul>
<p>These modules are still in active development, and we expect to make incompatible changes to them in future releases.</p>
<p>{{ LandingPageListSubpages ("/en-US/Add-ons/SDK/Low-Level_APIs", 5) }}</p>
<p>&nbsp;</p>
Revert to this revision